PayPal Elevated Errors
Incident Report for Refersion
Resolved
PayPal has resolved this issue.
Posted Sep 24, 2020 - 14:36 EDT
Identified
PayPal is experiencing elevated error rates. We are monitoring this issue and will provide updates as they become available.

More information: https://www.paypal-status.com/history/eventdetails/14300
Posted Sep 24, 2020 - 12:14 EDT
This incident affected: Client Dashboard (Base).