PayPal Degraded Performance
Incident Report for Refersion
Resolved
This issue has been resolved as of Wed, 26 May 2021 20:31 GMT.
Posted May 26, 2021 - 16:51 EDT
Monitoring
PayPal is currently experiencing issues with their payment platform and as a result, payments made in Refersion may have elevated error rates.

We are continuing to monitor the situation and will provide updates as they become available.
Posted May 26, 2021 - 16:43 EDT
This incident affected: Client Dashboard (Base).