Issues with login
Incident Report for Refersion
Resolved
According to our tests, the previous issue has been resolved but we will continue to monitor.
Posted 8 months ago. Mar 16, 2017 - 14:55 EDT
Investigating
We are currently investigating an issue with our account login system for merchants and affiliates. Until this is resolved some users may not be able to login. Click and order tracking is NOT affected.
Posted 8 months ago. Mar 16, 2017 - 11:47 EDT